投稿

2フォロワー フォローする
0
Avatar

6.8.1 正しく表示されないサイトがある(Gecko)

標準のレンダリングエンジンをGeckoで使っています。

http://www.neowing.co.jp/ebooks/

という電子書籍販売サイトがあるんですけど、

例えば「出版社から探す」で「●行(五十音順)」、というボタンをクリックしたら、

検索結果は「xx件」という表示があって、

明らかに 0 件ではないのに、出版社名などが全く表示されず、すぐ下の店舗のメニューだけが出てきます。

 

同じページで「Trident」に切り替えると、ちゃんと●行の出版社が一覧として出てきます。

「WebKit」では確認していません。(Chromeもインストしていません)

単にサイト側の対応ブラウザの問題でしょうか?(もしそうならサイトの表示エンジンを指定するだけですが)

Gecko に改善の余地があれば、対応よろしくお願いします。

 

以下に私のシステム情報をコピペしときます。(Microsoft、AdobeFlash、Java等のパッチ・VerUPは全て更新確認のうえ、最新にしています。)

Lunascape Core Version 6.8.1.25906 / Unicode
Operating System Version 6.0.6002
Internet Explorer Version 7.0.6002.18005
Gecko Plugin Version ... / Gecko 1.9.2.24
WebKit Plugin Version 1.3.7.25137 / WebKit 535.3 r95080
Memory Total,AvailPhys / 2098364416,899944448
Memory Total,AvailVirtual / 2147352576,1580478464
Processor Architecture,Type,Revision,NumberOfProcessors,OemId / 0,586,5894,2,0



Taia

ログインしてコメントを残してください。

2件のコメント

0
Avatar

Taia様

ご報告ありがとうございます。

Lunascapeで現在使用されているGeckoエンジンのバージョンと同じ、
Firefox 3.6 を使用して下記のサイトを閲覧すると、同様の現象が発生することを確認しました。

つきましては、Lunascape独自の問題ではなく、
サイト側の対応が必要不可欠な問題となります。

ご不便をおかけしますが、表示エンジンの切り替えを使用していただけますか。
Firefoxの最新バージョンでは発生しないことから、今後Geckoエンジンのバージョンアップ時に解決する可能性はございます。

Support Team 0 票
0
Avatar

返信ありがとうございます。

 

最近は、「Firefox4.0以上」等という対応表示があるサイトが増えてきました。

今、自分がインストしているFirefoxはまさに3.x系の最終版で、

それを起動すると常に「(Firefox)12にアップデートしてください」と表示が出ます。

Firefoxの公式サイトに行っても「4」とか以前のバージョンをダウンロードできません。(3.6はダウンロードリンク見ました。)

 

Lunascape の Gecko エンジンについては、Firefox のメジャーバージョンにあまりこだわらず、

開発を続行していただきたいと思います。(ライセンスが三重になっていて、ちょっと面倒くさそうな印象はありますが…。)

不快感を抱く宣伝ばかりのドメインを、右クリックだけで表示ブロックできるので気に入っているのです。

(そうすると今度はFlash広告に切り替わることも多いんですけどね。。)

 

件のサイトでは、表示エンジンを Trident に切り替えて利用することにします。

ありがとうございました。

Taia 0 票